Problem : Trouble passing traffic through IPSEC-IPSEC Spoof Detected

Problem : Trouble passing traffic through IPSEC-IPSEC Spoof Detected

I am trying to set up an alternative VPN server on our network. The outside interface is set to a public IP, and the inside interface is connected to one of our core switches, and able to freely access the inside network. My outside client connects fine, and split tunneling is working because they can still conect to external sites. They can’t however get to devices inside the network. I used the packet tracer and the packet is dropped because an IPSEC Spoof detected. I am sure it is a NAT problem, I guess I just don’t understand NAT well enough. I will paste my relevent config to see if someone can point me in the right direction. The internal network is 10.0.0.0./16 and the IP pool I have given VPN users is 192.168.250.0/24. There shouldn’t be any internal firewall blockage. Lines with XX i removed for security.

ASA Version 8.0(4)
!
hostname XX
domain-name XX
names
!
interface GigabitEthernet0/0
nameif outside
security-level 1
ip address 204.2.XXX.XXX 255.255.255.0
ospf cost 10
!
interface GigabitEthernet0/1
nameif inside
security-level 100
dhcp client route distance 2
ip address dhcp setroute
ospf cost 10
!
ftp mode passive
dns domain-lookup inside
dns server-group DefaultDNS
name-server 10.0.0.252
name-server 10.0.0.253
name-server 10.0.0.254
domain-name XX
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list inside_nat0_outbound extended permit ip any 192.168.250.0 255.255.255.0
access-list InsomVPN standard permit 10.0.0.0 255.255.0.0
access-list InsomVPN standard permit 192.168.0.0 255.255.0.0
access-list InsomVPN standard permit 192.168.20.0 255.255.255.0
access-list outside_access_in extended permit ip 192.168.250.0 255.255.255.0 any
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu management 1500
ip local pool InsomVPNpool 192.168.250.1-192.168.250.254 mask 255.255.255.0
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-613.bin
no asdm history enable
arp timeout 14400
nat-control
nat (inside) 0 access-list inside_nat0_outbound
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 204.2.209.1 1
route inside 0.0.0.0 0.0.0.0 10.0.0.1 3
route inside 10.0.0.0 255.255.0.0 192.168.20.2 1
route outside 0.0.0.0 0.0.0.0 192.168.20.2 tunneled
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server community insomniac
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime seconds 28800
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime kilobytes 4608000
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto map inside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map inside_map interface inside
crypto isakmp enable outside
crypto isakmp enable inside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcp-client client-id interface inside
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection scanning-threat shun except ip-address 10.0.0.0 255.255.0.0
threat-detection statistics host
threat-detection statistics port
threat-detection statistics protocol
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
group-policy insomVPN internal
group-policy insomVPN attributes
vpn-simultaneous-logins 3
vpn-idle-timeout none
vpn-session-timeout none
vpn-tunnel-protocol IPSec l2tp-ipsec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value InsomVPN
default-domain value XX
vlan none
username downscm password BBMZjP/C8CdwwPEI encrypted privilege 15
tunnel-group insomVPN type remote-access
tunnel-group insomVPN general-attributes
address-pool InsomVPNpool
default-group-policy insomVPN
tunnel-group insomVPN ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:988b255ae409fd61e215c53e04a1f856
: end
asdm image disk0:/asdm-613.bin
no asdm history enable


Solution : Trouble passing traffic through IPSEC-IPSEC Spoof Detected
Well the nonat and nat 0 are for NAT bypass(do nat not this) so i just changed the name of your inside_nat0_outbound so it makes sense since your are trying to use this ACL to classify traffic for NATing. The NONAT is to tell it what not to NAT. I also made the NAT ACl more specific to your inside address only, so again here is the config, and yes I would delete inside_nat0_outbound  and create NONAT and inside_outbound

You have this;
nat-control
nat (inside) 0 access-list inside_nat0_outbound
access-list inside_nat0_outbound extended permit ip any 192.168.250.0 255.255.255.0

(this says do not nat from inside to 192.168.250.0 255.255.255.0, but there is no matching global command so NAT is not working)

change to;
nat-control
nat (inside) 1 access-list inside_outbound
nat (inside) 0 access-list NONAT
global (outside) 1 interface
access-list inside_outbound extended permit ip 10.0.1.109 255.255.0.0 any
access-list NONAT extended permit ip any 192.168.250.0 255.255.255.0